DirectX 診斷工具

[Microsoft® DirectX® 診斷工具] 說明文件包含下列主題：

  • 關於「DirectX 診斷工具」
  • 搜尋內容
  • 測試 DirectX 元件
  • 覆寫預設行為


關於「DirectX 診斷工具」

[Microsoft® DirectX® 診斷工具] 提供系統上 DirectX 應用程式介面 (API) 元件及驅動程式的相關資訊。它可讓您測試音效及圖形輸出，以及 Microsoft DirectPlay® 服務提供者。它也使您能夠關閉一些硬體加速功能。

您可以使用此工具在撥支援電話的過程中為技術人員收集資訊，或者儲存此工具收集的資訊並將這些資訊貼上到電子郵件中。

資訊在一系列頁面上顯示。您可以使用下列方法在頁面之間移動：

  • 按一下索引標籤。
  • 按一下 [下一頁] 按鈕。
  • 當輸入焦點位於索引標籤上時，請按向左鍵或向右鍵。

您可以指定此工具如何顯示表格。若要做這樣的處理，請選擇要對表格列進行排序的欄位。按一下該欄位頂端的標題按鈕，表格會依英文字母順序或數字順序來對該欄位中的項目進行排序。若要將排序順序反向，請再按一下標頭按鈕。

您可以按一下 [儲存所有資訊] 按鈕，以將全部資訊儲存到文字檔案。

注意事項

  • 部份資訊 (如顯示卡上的記憶體數量) 可能為大約值。


搜尋內容

如果在執行 Microsoft(R) DirectX(R) 應用程式時遇到問題，則 [DirectX 診斷工具] 可以幫助您尋找問題的來源。您應該搜尋的部份內容如下：

  • DirectX 元件的錯誤版本：在 [DirectX 檔案] 頁面的 [注意事項] 區段中，搜尋測試及偵錯檔案的警告。測試檔案是早期的測試版本，不可與商業應用程式一起安裝。偵錯版本 (用於程式開發，並且同樣不可與最終產品一起安裝) 可能會導致應用程式的執行比在元件的零售版下慢。
  • 缺少硬體加速功能：除非可以使用 Microsoft DirectDraw(R) 或 Direct3D(R) 硬體加速，否則部份程式的執行會十分緩慢 (或根本無法執行)。在 [顯示] 頁面上，於 [DirectX 功能] 下查看 DirectDraw 加速、Direct3D 加速或 [AGP 材質加速] 速是否標記為 [無法使用]。如果這樣的話，您可以要考慮升級您的硬體。
  • 裝置尚未連接： 如果搖桿或其他輸入裝置無法回應，則其可能尚未正確設定。請確定該裝置在 [DirectX 診斷工具] 的 [輸入] 頁面上。如果沒有的話，則透過 [控制台] 新增該裝置。
  • 未簽署的驅動程式：Microsoft 尚未使用 DirectX 最新的版本來測試未簽署的驅動程式是否完全相容。這些驅動程式會列在適當的元件頁面。

注意事項： 如果您使用 [終端機服務] 在支援硬體加速功能的遠端系統上運作，則 [DirectX 診斷工具] 可能會指出硬體加速功能的支援。不過，[終端機服務] 無法使用硬體加速功能，因此無法使用支援。


測試 DirectX 元件

您可以在連接系統的每個監視器上測試 Microsoft(R) DirectDraw(R) 及 Direct3D(R)。您亦可在每個聲音輸出裝置上測試 DirectSound(R)，並在每個音樂連接埠上測試 DirectMusic(R)。

若要測試 DirectX 功能：請在適當的頁面上按一下 [測試] 按鈕、讀取出現的訊息，並觀察或聽取測試。在看到詢問測試是否成功的訊息之前，請讓每個測試一直執行。如果您回應 [否]，則不會再執行測試。

DirectMusic 僅有單一測試。當您對正確播放 (或未正確播放) 的音樂感到滿意，請按一下 [確定]。

您可以在任意可用的服務提供者上測試 Microsoft DirectPlay(R) 功能。

測試 DirectPlay

  1. 在 [網路] 頁面上按一下 [測試 DirectPlay]。在 [DirectPlay 測試] 對話方塊中鍵入使用者名稱，並選擇服務提供者。選取 [建立新工作階段] 並按一下 [確定]。如果已選擇了數據機連線，則在 [數據機連線] 對話方塊中按一下 [回答]，以將數據機變為自動回答模式。
  2. 在可建立與第一台電腦之選定連線的其他電腦上，立即執行 [Microsoft DirectX(R) 診斷工具]。按一下 [測試 DirectPlay]，鍵入不同的使用者名稱，並選擇同一服務提供者後，再按 [加入現存的工作階段] 按鈕並按 [確定]。

    若為部份類型連線，系統可能要求您提供相關資訊 (如電話號碼)。若為本端網路上的 TCP/IP 連線，您可以將文字方塊留為空白。

  3. 在第二台電腦上，在包含您在第一台電腦上所建立之工作階段名稱的 [工作階段清單] 中，選取工作階段的名稱，再按 [確定]。
  4. 兩台電腦都應立即顯示聊天對話方塊。在一台電腦上的輸入方塊中輸入訊息，再按 [傳送]。訊息應出現在兩台電腦上聊天對話方塊的捲動區域中。


覆寫預設行為

在 [音樂] 頁面上，您可以藉由移動滑桿來設定硬體加速的不同等級。此等級在關閉 [Microsoft(R) DirectX(R) 診斷工具] 之後仍持續有效。

您可以停用 Microsoft DirectDraw(R) 或 Direct3D(R) (如果這樣的硬體加速是可用的)。若要做這樣的處理，請跳至每個顯示裝置的 [顯示] 頁面，並按一下 [停用] 按鈕。一旦停用硬體加速，則即使關閉 [DirectX 診斷工具]，應用程式亦無法再使用該硬體加速。若要重新啟用硬體加速，請在適當的 [顯示] 頁面上按一下 [啟用] 按鈕。

注意事項

  • 停用 DirectDraw 加速亦會停用 Direct3D 的加速。

您亦可覆寫由 DirectDraw 全螢幕應用程式所設定的監視器重新整理速率。僅當您遇到應用程式的顯示問題，且有理由相信該應用程式設定了無效的重新整理速率時，您才應該做這樣的處理。

設定覆寫重新整理速率

  1. 在 [其他說明] 頁面上，按一下 [強制覆寫] 按鈕。
  2. 在 [強制覆寫 DirectDraw 的重新整理行為] 對話方塊中，選取編輯方塊，並為監視器輸入有效的重新整理速率。

    當您做這樣的處理時，系統會自動選取 [強制覆寫數據] 選項按鈕。

  3. 按一下 [確定]。

取消覆寫重新整理速率並讓 DirectDraw 應用程式來設定自己的重新整理速率

  1. 在 [其他說明] 頁面上，按一下 [強制覆寫] 按鈕。
  2. 在 [強制覆寫 DirectDraw 的重新整理行為] 對話方塊中，選取 [預設值] 選項按鈕，並按一下 [確定]。